Coolant Leak - Interior
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Coolant Leak - Interior

  1. #1
    Registered User
    Join Date
    Mar 2024
    Location
    Warwickshire
    Posts
    16

    Default Coolant Leak - Interior

    Hi

    Still waiting to receive the questionnaire for full access but in the meantime... I have noticed a strong smell of coolant in the cabin once the car is up to temperature. On investigation today (the car has not been used so cold) I have found evidence of a leak in the drivers foot well, next to the clutch pedal. I have attached an image..

    It looks to me like the middle hose isn't properly seated or is this wishful thinking? I am aware that there is a 3 way valve above this just out of shot, but that part appears to be unobtainable. I've only had a quick look so far as it started to rain quite heavily, hoping to get a dry day this weekend.

    If it is the valve, how would I approach this going forward? I only bought the car a week ago (privately, and I don't recall smelling coolant on the test drive)

    Thanks in advance,

    Ben

    leak.jpg

  2. #2
    #829 called 'Olive' David's Avatar
    Join Date
    Jun 2015
    Location
    Breugel, Holland
    Posts
    6,022

    Default

    Quote Originally Posted by WelshPetrolhead View Post
    Hi

    Still waiting to receive the questionnaire for full access but in the meantime... I have noticed a strong smell of coolant in the cabin once the car is up to temperature. On investigation today (the car has not been used so cold) I have found evidence of a leak in the drivers foot well, next to the clutch pedal. I have attached an image..

    It looks to me like the middle hose isn't properly seated or is this wishful thinking? I am aware that there is a 3 way valve above this just out of shot, but that part appears to be unobtainable. I've only had a quick look so far as it started to rain quite heavily, hoping to get a dry day this weekend.

    If it is the valve, how would I approach this going forward? I only bought the car a week ago (privately, and I don't recall smelling coolant on the test drive)

    Thanks in advance,

    Ben
    Yes that is the 3-hose, 2-way balance valve, or a hose to it. They were available exchange from Austin Garages a little while back for around £200 (admin@austingarages.co.uk). Unsure if they still have one. Drop them an email. Specify balance valve and RHD ZT260 (Rovers are 4-hose, and LHD are different).
    Alternative is DMGRS. Make sure you specify the balance valve under the dash NOT the plenum valve. Again unsure about the valve being a direct fit. Someone here modified a valve to work though, and I'll try and sort out the reference later today. Busy now with a gutted interior fixing a sunroof rain-water leakage, and need this single dry day!

    David
    Last edited by David; 16-03-2024 at 09:31 AM.

  3. #3
    Registered User Pete's Avatar
    Join Date
    Aug 2016
    Location
    Nottinghamshire
    Posts
    943

    Default

    Ben

    As you observe the middle hose clip looks like it's too far away from the joint. Maybe sitting on the bulbous annulas. Maybe refitted by PO. 3 Way valve in club shop. Info on here. This is one Heater leaking problems - Page 2 (two-sixties.co.uk)

    Last edited by David; 16-03-2024 at 05:39 PM.
    I used to be indecisive but now I'm not so sure.
    When you have eliminated the impossible, whatever remains, however improbable, must be the truth

    2004 MG ZT 260SE Pearl Black
    1960 MGA Roadster Flame Red

  4. #4
    #829 called 'Olive' David's Avatar
    Join Date
    Jun 2015
    Location
    Breugel, Holland
    Posts
    6,022

    Default

    Quote Originally Posted by Pete View Post
    Ben

    As you observe the middle hose clip looks like it's too far away from the joint. Maybe sitting on the bulbous annulas. Maybe refitted by PO. 3 Way valve in club shop. Info on here. This is one Heater leaking problems - Page 2 (two-sixties.co.uk)
    Yes that's the post I was referring to from jeffturbo. The vlave he used is from DMGRS sold normally as a plenum valve and modified. Extensive description on "how to" in the thread, but Ben has no access to it yet! If its not just a misplaced hose, best to contact Austin Garages and/or DMGRS right away.

    Any way to 'fast-track' full membership for him Tim, Nich ?

    David

  5. #5
    Administrator Nich's Avatar
    Join Date
    May 2006
    Location
    Surrey, United Kingdom.
    Posts
    10,289

    Default

    Quote Originally Posted by David View Post
    ...................

    Any way to 'fast-track' full membership for him Tim, Nich ?

    David
    Done.

    Nich.
    Nicholas John Peter Tinker - # 484

    Manufactured on Tuesday 27th April 2004 @ 12.17.47.
    Commission Number: 24468.
    Brochure Model: M3 Tourer 4.6 V8 260PS.
    Specification Code: L01B.
    CICode: D1511.
    Trim Level: TL8.9 (M3).

    65th ZT-T 260SE to be made out of 115.
    11th ZT-T 260 SE in Pearl Black (PBT) out of 23 produced.

    Manufactured in the UK by MG Rover Group Ltd.


  6. #6
    Registered User
    Join Date
    Mar 2024
    Location
    Warwickshire
    Posts
    16

    Default

    Thanks Guys for your help so far. Nich, I've had the questionnaire and sent it back to Tim. I'm just waiting on my MGOC number as I've done that today too.

    Luckily it was a dry morning so I got out, removed the panel under the steering wheel to get a better look. I mopped up what I could get to with some tissue to dry it. Tried jiggling that hose inwards but its going nowhere...Is it just a case of pinching the clip to loosen, push hose on more and release the clip?? I'm wary of disturbing anything at the moment.

    Took the car out for a run to get it up to temperature, started to get a whiff of coolant. I then changed the settings on the climate (which was set to auto), up to 23 degrees, and the dashboard/face vents. Interestingly the coolant smell faded. Got the car back on the drive, left it running and got into the footwell to have a look and its the same as after I cleaned it up. I will check the car later once it is fully cold, to see if there is any change to the footwell area but also check the coolant level.

    As a side note, the car has the DMGRS plenum valve fitted, I have an invoice for both the part itself, and another for fitting it, and even the old part in a box... The car came with a box of bits and I have what I assume is the club 3 way valve (The box it was in has Tim's name and address on it!) The actuator on top has a Bosch VW/Audi label. I thought that this was a spare for the plenum valve or an upgrade over the DMGRS one. I will check out the thread above, but could this be used for the interior valve?

    I've taken a few pics of the area, the valve doesn't look terrible from what I can see, so perhaps its a minor weep. The new assumed club valve is in pic 5

    PXL_20240316_125313734.jpgPXL_20240316_125241041.jpgPXL_20240316_125337146.jpgPXL_20240316_125401921.jpgPXL_20240316_140340077 (1).jpg

  7. #7
    #829 called 'Olive' David's Avatar
    Join Date
    Jun 2015
    Location
    Breugel, Holland
    Posts
    6,022

    Default

    Quote Originally Posted by WelshPetrolhead View Post
    Thanks Guys for your help so far. Nich, I've had the questionnaire and sent it back to Tim. I'm just waiting on my MGOC number as I've done that today too.
    I see your name is already showing Green, meaning you now have full member access status.

    Luckily it was a dry morning so I got out, removed the panel under the steering wheel to get a better look. I mopped up what I could get to with some tissue to dry it. Tried jiggling that hose inwards but its going nowhere...Is it just a case of pinching the clip to loosen, push hose on more and release the clip?? I'm wary of disturbing anything at the moment.
    Understand your reluctance, but yes

    Took the car out for a run to get it up to temperature, started to get a whiff of coolant. I then changed the settings on the climate (which was set to auto), up to 23 degrees, and the dashboard/face vents. Interestingly the coolant smell faded. Got the car back on the drive, left it running and got into the footwell to have a look and its the same as after I cleaned it up. I will check the car later once it is fully cold, to see if there is any change to the footwell area but also check the coolant level.
    That figures. The balance valve probably works then

    As a side note, the car has the DMGRS plenum valve fitted, I have an invoice for both the part itself, and another for fitting it, and even the old part in a box... The car came with a box of bits and I have what I assume is the club 3 way valve (The box it was in has Tim's name and address on it!) The actuator on top has a Bosch VW/Audi label. I thought that this was a spare for the plenum valve or an upgrade over the DMGRS one. I will check out the thread above, but could this be used for the interior valve?

    I've taken a few pics of the area, the valve doesn't look terrible from what I can see, so perhaps its a minor weep. The new assumed club valve is in pic 5
    I found this thread from the last owner, but is not really clear what has been done:
    https://www.two-sixties.co.uk/mgoc26...4-Heater-Valve
    If it transpires that the problem looks like more than a leaking hose joint, try and call Dom to ask which, if not both, of the valves have indeed been changed, and how. I'm assuming that the Two-Sixties valve has been fitted, or waiting to be fitted, as intended in the plenum (main Hot/Cold valve) and the other DMGRS one is the one now leaking, modified and operating as a replacement Balance valve.

    David
    Last edited by David; 16-03-2024 at 03:39 PM.

  8. #8
    Registered User
    Join Date
    Mar 2024
    Location
    Warwickshire
    Posts
    16

    Default

    Thanks David!

    I contacted Dom who clarified that the foot well balance valve was replaced with the DMGRS plenum item, that was done in January 2021. The club valve is waiting to go into the plenum.

    It's raining now, so will have another investigate when its dry, and see if I can tend to the suspect hose. Will also check the condition of the plenum valve.

    Ben

  9. #9
    #829 called 'Olive' David's Avatar
    Join Date
    Jun 2015
    Location
    Breugel, Holland
    Posts
    6,022

    Default

    Quote Originally Posted by WelshPetrolhead View Post
    Thanks David!

    I contacted Dom who clarified that the foot well balance valve was replaced with the DMGRS plenum item, that was done in January 2021. The club valve is waiting to go into the plenum.

    It's raining now, so will have another investigate when its dry, and see if I can tend to the suspect hose. Will also check the condition of the plenum valve.

    Ben
    That's positive. Could still be a leaky balance valve of course, but probably just the hose connection. Usure about the expected lifespan of the DMGR units. If the heating and airco appears to be behaving, I would leave the plenum valve switch, at least for now. They are good, but can be tricky to set up.

    Davi

  10. #10
    Registered User
    Join Date
    Mar 2024
    Location
    Warwickshire
    Posts
    16

    Default

    Quote Originally Posted by David View Post
    That's positive. Could still be a leaky balance valve of course, but probably just the hose connection. Usure about the expected lifespan of the DMGR units. If the heating and airco appears to be behaving, I would leave the plenum valve switch, at least for now. They are good, but can be tricky to set up.

    Davi
    Yeah the heating/aircon appears to be functioning okay. It's just the coolant smell. Will look at the hoses ASAP and then go from there.

    Ben

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •