Fuel pump issues - ZT 260
Results 1 to 3 of 3

Thread: Fuel pump issues - ZT 260

  1. #1
    Registered User
    Join Date
    Dec 2020
    Location
    Australia
    Posts
    2

    Default Fuel pump issues - ZT 260

    Hi all
    MG 260 ZT - in Australia. #691
    I picked this car up at an auction in November and have only just pulled my finger out to get it running. Has only 74800klms as was with a collector for many years not used. As it is my first MG it has been a challenge to get info or make contact with other owners other than Facebook and this site.
    I have an issue and need help. Yes lost if detail on fuel issues and post but just donĀ?t cover it all. I have had a fuel issue and have removed the fuel pump. I have received a new pump but cannot get the original one out of the housing.
    this vehicle has been sitting since 2014 so fuel has left a mess and fuel pump has died.
    So have started the challenge of replacing the pump. Challenging but was keen to have a crack myself.
    I have power to the pump but it does not run. Feel a new pump should help the situation.
    any feedback or photos would be helpful.
    Mick #691

  2. #2
    Administrator Nich's Avatar
    Join Date
    May 2006
    Location
    Surrey, United Kingdom.
    Posts
    9,804

    Default

    Hi Mick, welcome to the 260's. The first thing you need to do is to get your questionnaire back to Tim to get full access to the 260's forum. That way you will be able to access lots of information, which at the moment, is hidden from you.

    Nich.
    Nicholas John Peter Tinker - # 484

    Manufactured on Tuesday 27th April 2004 @ 12.17.47.
    Commission Number: 24468.
    Brochure Model: M3 Tourer 4.6 V8 260PS.
    Specification Code: L01B.
    CICode: D1511.
    Trim Level: TL8.9 (M3).

    65th ZT-T 260SE to be made out of 114.
    11th ZT-T 260 SE in Pearl Black (PBT) out of 23 produced.

    Manufactured in the UK by MG Rover Group Ltd.


  3. #3
    Registered User
    Join Date
    Dec 2020
    Location
    Australia
    Posts
    2

    Default

    Hi Nich
    I have sent it twice so will attempt to send it again.
    thanks
    Mick

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •